Unity에서 SmartBeat를 설치하려고 하면 「Undefined symbols for architecture arm64:」 오류가 나서 빌드할 수 없습니다.

Unity 2019.3 이후 버전에서 SmartBeat를 설치할 경우, 이전 버전의 SmartBeat Unity SDK에서 빌드할 때 다음과 같은 오류가 발생할 수 있습니다.

Unity 2019.3 이후 버전을 이용하는 경우에는 최신 버전의 SmartBeat Unity SDK(Version 1.21 이상)를 이용하시기 바랍니다.

 

참고: 오류 내용

Undefined symbols for architecture arm64: 
"__mh_execute_header", referenced from: 
+[SmartBeatUtil getBuildUuid] in libSmartBeat.a(SmartBeatUtil.o)

 

 

도움이 되었습니까?
0명 중 0명이 도움이 되었다고 했습니다.
또 다른 질문이 있으십니까? 문의 등록
Zendesk 제공